Because SpatialKey runs in all modern web browsers, it is not tied to any particular operating system and can be used on almost any desktop or laptop computer with an Internet connection.

System requirements are as follows:

  • OS: Windows 7+, Linux, Mac OS X
  • Browser and version: IE 11.0, Edge, Chrome
  • Adobe® Flash® Player 11.0+
  • CPU: Intel® Pentium® 4 or faster processor, AMD Athlon
  • RAM: 1GB minimum (2GB+ recommended)
  • Display: 1,024×768 minimum
  • Internet connection: SpatialKey will work over mobile broadband cards but a cable or DSL connection is recommended (1Mb+ is recommended)
  • Pop up blocker settings: For exports to work correctly, popup blockers should be disabled for your SpatialKey site
  • PDF reader: For PDF file generation to work correctly, a PDF reader must be installed

Older version of Internet Explorer No Longer Supported
Microsoft discontinued all support and updates for Internet Explorer 8, 9 and 10 on January 12, 2016. These old versions of IE will not receive any further security updates. If your organization is still running old versions of Internet Explorer please contact your IT department and upgrade immediately.